Microsoft 365 - Global Instability

Incident Report for Deepsea Technologies UK

Resolved

Microsoft have confirmed that worldwide services have now returned to 99% of their normal level.
Posted Jul 21, 2022 - 20:41 UTC

Monitoring

Microsoft have experienced global disruption to various services overnight due to a failed deployment on their side.

As of 05:30 there are still intermittent performance issues remaining with:
* Microsoft Outlook (and all email traffic)
* Microsoft Teams
* Microsoft Office 365

---------------------------

Microsoft Incident: MO402741

Current status: We’re observing continued improvement for a majority of the functions within the Microsoft 365 apps. We’re focused on the areas that have not recovered and are taking action to restore service at the highest priority.

Root cause: A recent deployment contained a broken connection to an internal storage service, which is causing an issue in which users may be unable to access or use various Microsoft 365 apps or functions.
Posted Jul 21, 2022 - 07:21 UTC
This incident affected: Email, Conferencing & Office Apps (Microsoft Outlook, Microsoft Teams, Microsoft Office 365).