Microsoft Outlook Disruption and associated network slow down

Incident Report for Deepsea Technologies UK

Resolved

This incident has been resolved.
Posted Oct 12, 2023 - 07:53 UTC

Update

This issue is still ongoing and is now known to be affecting a significant percentage of Microsoft’s servers across the world.

Microsoft have traced the root cause of this issue to a change which they applied to a section of their infrastructure responsible for IP address-based spam filtering in the early hours of this morning.

They are currently working on a fix, no firm timeline has been given but this is not expected to be ready until well after midnight and is likely to continue in to tomorrow morning.

There are severe delays to email traffic across the globe, for any urgent or time sensitive communications please use phone calls, teams calls or teams messages.

If your computer or your network connection is running very slowly, you should see a noticable performance benefit from closing Outlook and leaving it closed and just opening it to check email periodically.

No further update is expected from Microsoft until the early hours of tomorrow morning.
Posted Oct 11, 2023 - 15:17 UTC

Identified

Due to a fault at Microsoft, there is currently widespread disruption to Microsoft Outlook email services across the UK and Europe.

Emails between European companies are currently subject to delays of up to one hour.

At times, your computer / network connection / internet speeds might appear to slow down to an unusable level. If this happens, please close Outlook and leave it closed which should restore normal performance. You can try reopening it after a short time.

A further update is expected from Microsoft at 11:30am.
Posted Oct 11, 2023 - 09:48 UTC
This incident affected: Email, Conferencing & Office Apps (Microsoft Outlook).